AForge.NET

  :: AForge.NET Framework :: Articles :: Forums ::

Capturing Video from tv tuner card

The forum is to discuss topics related to different areas of image processing and computer vision.

Capturing Video from tv tuner card

Postby prodigyaj » Mon Mar 16, 2009 12:42 pm

Hy all !!

I have developed algorithms for video streams from web camera. Now I wish to extend the algortihms using a wireless cam. For me to interface the wireless cam i require the tv tuner card. I am able to get the video streams from the wireless cam to the comp using the software that comes along with tv tuner card. How do i aquire these images on to my C# forms like we do to aquire videos streams from web cam ?

Regards

AJ
prodigyaj
 
Posts: 13
Joined: Mon Mar 16, 2009 12:37 pm

Re: Capturing Video from tv tuner card

Postby prodigyaj » Mon Mar 16, 2009 1:01 pm

Also let me add, when i use the Motion detector sample code, on capture it gives me an option of conexant capture ! However nuthing happens after that !!

Regards

AJ
prodigyaj
 
Posts: 13
Joined: Mon Mar 16, 2009 12:37 pm

Re: Capturing Video from tv tuner card

Postby prodigyaj » Mon Mar 16, 2009 2:10 pm

A new development which makes me feel closer to my goal !

I switch on my original C# code and the camera select window prompts me 'conexant capture' (which is the tv tuner card processor) click ok and as usual comes the grained screen ( as seen on tv when cable is unplugged ). Now I open the tv tuner card default software , although the tv tuner is not able to connect with my wireless cam but astonshingly it the grained picture starts streaming te wireless video streams. Now ican switch off the tuner card software and still the streaming continues and i m able to use my original IP codes

Is there any way i can have the entire thing in my control ?

Regards

AJ
prodigyaj
 
Posts: 13
Joined: Mon Mar 16, 2009 12:37 pm

Re: Capturing Video from tv tuner card

Postby andrew.kirillov » Mon Mar 16, 2009 3:10 pm

Hello,

I had similar problem in the past, but it was not hard to fix in my case. I have a wireless analogue camera, receiver and then USB capture board, which gets signal from receiver and produces digital images. Initially I had the same problem as you - it was possible to detect the device (in Motion Detection sample, for example), but no correct output. Then I used software, which was provided with capture board, and after changing some setting I got a view from my camera. Try experimenting with video signal setting, like PAL, NTSC, etc.
With best regards,
Andrew


Interested in supporting AForge.NET Framework?
User avatar
andrew.kirillov
Site Admin, AForge.NET Developer
 
Posts: 3439
Joined: Fri Jan 23, 2009 9:12 am
Location: UK




Return to Image Processing and Computer Vision