AForge.NET

  :: AForge.NET Framework :: Articles :: Forums ::

Cannot connect to webcam (Connecting...) Windows 10 Surface

Forum to discuss AForge.NET Framework, its features, API, how-tos, etc.

Cannot connect to webcam (Connecting...) Windows 10 Surface

Postby evoCom » Mon May 27, 2019 6:52 am

Hi everyone,

I have implemented a way to take a picture with the integrated camera(s) in my application. Worked fine for years.
Since 2-3 weeks, the camera / videosourceplayer keeps stuck at "Connecting...". The test application "two camera test" gives the same result, both cameras are "Connecting..." and at 0 FPS.
Other camera apps are working fine - so i assume there is problem with AForge <-> Windows.
The customers device: Surface 3 with LTE - Windows 10 Version 1803 Build 17134.765. Latest drivers are installed.

On my development machine (no surface), the camera shows up fine without problems.

Any ideas?

Thanks!
Marcel
evoCom
 
Posts: 3
Joined: Mon May 27, 2019 6:46 am

Re: Cannot connect to webcam (Connecting...) Windows 10 Surf

Postby andrew.kirillov » Tue May 28, 2019 8:34 am

Hello,

Do you get anything in VideoSourceError event? If you have access to that Surface 3 device and can put dev tools on it, then maybe debugging with AForge.NET source code could help finding the issue.
With best regards,
Andrew


Interested in supporting AForge.NET Framework?
User avatar
andrew.kirillov
Site Admin, AForge.NET Developer
 
Posts: 3404
Joined: Fri Jan 23, 2009 9:12 am
Location: UK

Re: Cannot connect to webcam (Connecting...) Windows 10 Surf

Postby evoCom » Wed Jun 05, 2019 10:42 am

andrew.kirillov wrote:Hello,
Do you get anything in VideoSourceError event?

I added the VideoSourceError event in my code, but it is not fired. So i guess, there is no error.

andrew.kirillov wrote: If you have access to that Surface 3 device and can put dev tools on it, then maybe debugging with AForge.NET source code could help finding the issue.

Nope, that is not so easy to realise. The device is 800km away and in use by the customer.

Any other ideas? :-)
evoCom
 
Posts: 3
Joined: Mon May 27, 2019 6:46 am

Re: Cannot connect to webcam (Connecting...) Windows 10 Surf

Postby andrew.kirillov » Thu Jun 06, 2019 9:55 am

Unfortunately it is hard to advice possible solution. The issue may be specific to the device/camera/OS and may require a fix in the AForge.NET Framework. However it is hard to provide possible fix without being able to reproduce the issue.

If the customer is willing to get the fix, maybe he could provide you temporary remote access to the device ...
With best regards,
Andrew


Interested in supporting AForge.NET Framework?
User avatar
andrew.kirillov
Site Admin, AForge.NET Developer
 
Posts: 3404
Joined: Fri Jan 23, 2009 9:12 am
Location: UK

Re: Cannot connect to webcam (Connecting...) Windows 10 Surf

Postby evoCom » Fri Jun 07, 2019 9:10 am

I asked the customer to send the device to me or to provide a stable remote connection. This may take some weeks. Anyway, once I have new information, I will let you know.

Thanks!
evoCom
 
Posts: 3
Joined: Mon May 27, 2019 6:46 am




Return to AForge.NET Framework