AForge.NET

  :: AForge.NET Framework :: Articles :: Forums ::

Unable to preview camera

Forum to discuss AForge.NET Framework, its features, API, how-tos, etc.

Unable to preview camera

Postby luiey » Wed Nov 13, 2019 4:13 am

I want to create a preview webcam and get the snapshoot of the image. But I cannot initialize the camera. I have built-in notebook web camera and logitech portable web camera. As image below, I have also download sample AForge program to test but it failed. BUT, when using Win10 Camera app, it can show both camera. Any help/clarification to handle this?

Two Cameras Test
Image

Simple Player
Image

Win10 Camera App
HP HD Camera
Image

Logitech
Image

Code snippet follow sample from:
AForge-examples
Video Samples
luiey
 
Posts: 1
Joined: Wed Nov 13, 2019 3:48 am

Re: Unable to preview camera

Postby andrew.kirillov » Wed Nov 13, 2019 8:59 am

I would suggest debugging with the source code. See how far camera configuration gets, if you get any video frames, etc. Also make sure cameras are not in use by another application.
With best regards,
Andrew


Interested in supporting AForge.NET Framework?
User avatar
andrew.kirillov
Site Admin, AForge.NET Developer
 
Posts: 3453
Joined: Fri Jan 23, 2009 9:12 am
Location: UK

Re: Unable to preview camera

Postby Scott Maxwell » Sun Jan 05, 2020 11:50 am

andrew.kirillov wrote:I would suggest debugging with the source code. See how far camera configuration gets, if you get any video frames, etc. Also make sure cameras are not in use by another application.


Faced with a similar problem. How do I know that the camera is not used by another application?
Scott Maxwell
 
Posts: 2
Joined: Mon Dec 30, 2019 7:49 am




Return to AForge.NET Framework